{
...
}:
let
icecast-nix = builtins.fetchGit {
url = "https://github.com/Jaculabilis/icecast.nix.git";
ref = "master";
rev = "fcdff3d46e6aad6328eae19e482bebe224a6be29";
};
in
{
imports = [ "${icecast-nix}/module.nix" ];
services.icecast = {
enable = true;
listen.address = "10.22.20.1";
listen.port = 8688;
secretsFile = "/etc/icecast";
extraConf = ''
empyrean
tvb
@@SOURCE_PASSWORD@@
'';
};
networking.firewall.allowedTCPPorts = [ 8688 ];
}