intake/flake.nix

41 lines
835 B
Nix

{
description = "Universal and extensible feed aggregator";
inputs = {
flake-parts.url = "github:hercules-ci/flake-parts";
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
};
outputs =
inputs@{ flake-parts, ... }:
flake-parts.lib.mkFlake { inherit inputs; } {
systems = [
"x86_64-linux"
"aarch64-linux"
"aarch64-darwin"
"x86_64-darwin"
];
perSystem =
{
pkgs,
...
}:
{
formatter = pkgs.nixfmt-rfc-style;
devShells.default = pkgs.mkShell {
packages = [
pkgs.go
pkgs.gopls
pkgs.go-tools
pkgs.gotools
pkgs.cobra-cli
pkgs.air
];
};
};
flake = {
};
};
}